AnsweredAssumed Answered

How to use RTI in STOP3 mode

Question asked by David Perreault on Dec 9, 2014
Latest reply on Dec 9, 2014 by David Perreault

Hi,

 

I have project working on the GT16 and designed with CodeWarrio 10.3 and migrated to 10.6.

 

With Device Initialization (why that nice feature disappeared in 10.6?), I can see all the modules used for that microcontroller. The RTI is not used and I clicked on it to be able to configure it:

 

Clock select = Internal oscillator

Prescaler = 1024

Real-Time interrupt = Enabled

 

When doing that, I can see this warning message:

 

Warning: Internal oscilator is used as a clock source - RTI won't be active in run and wait modes! (Clock select)

 

Hey Freescale, there is a typo on the "oscillator" ! ;-)

 

Ok, what I understand from that warning message is the RTI won't be triggered if I am on run or wait mode. Correct?

 

If I execute a stop, the RTI should be working, correct?

 

I compiled and uploaded the code to my chip and got to the point where the STOP3 mode is executed (asm STOP). I expected to see the breakpoint put in the RTI interrupt to be triggered, but nothing happened.

 

 

Any clue why it does not work? What did I forget to configure? Does the warning message could be the cause of my problem?

 

 

Big thanks in advance!

Outcomes