AnsweredAssumed Answered

FRDM-KL25Z fail to connect

Question asked by Kirk Gossage on Nov 12, 2014
Latest reply on Nov 12, 2014 by Kirk Gossage

When I first connected the board I got today I plugged it in to the non-SDA usb port and the installed app seemed to work.  I then plugged into the open-sda usb port and got the MSD to show in windows Explorer (64-bit WIndows 8.1) and the little green LED started blinking.  I tried to drag over

srec files from the Precompiled Examples, but they seem to have no effect and the pre-installed app no longer worked.  I repeatedly tried to drag different srec files, wait for a while, unplug/replug, nothing worked.  I then decided maybe the MSD bootloader was outdated so I unplugged the device, held down reset, plugged into open-sda port, and bootloader MSD popped up in Explorer.  I dragged the latest version of MSD-FRDM-KL25Z_Pemicro_v105.SDA over, unplugged, replugged, and now the regular MSD doesn't even load!!!  At this point all I can do is enter bootloader program mode.  I can no longer enter the regular MSD loader, and no apps seem to run.  The info from the SDA_INFO.htm in the bootloader MSD shows:

 

Board Name is: FRDM-KL25Z

MicroBoot Kernel Version is: 1.05

Bootloader Version is: 1.09

Application Version is: 0.00

DUID is: FFE33938-8DA081AE-3752F808-B74DE678

EUID is: F781A239-1FBA8720-1851DA1B-955668D6

TUID is: 74823938-473281DD-375E980F-B85CE678

TOA is: 86B6E505-B2A9F1EF-41E6B687-76977D16

TOA2 is: 86B6E505-02E1AE6E-CDE430D7-852E4389

SUID is: 86B6E505-6C47A61D-37239804-8003EC65

 

Can someone please tell me what I'm doing wrong?  At this point this board seems to be in a useless state.  Thanks

 

Kirk

Outcomes