David Cantero

Shell echo off

Discussion created by David Cantero on Nov 5, 2014
Latest reply on Nov 6, 2014 by gilles buloz

How can I disable the MQX shell echo?

I´m working with MQX 4.1 and I need to disable shell echo. I have changed the "BSP_DEFAULT_IO_OPEN_MODE" define in "twrk70f120m.h" removing the IO_SERIAL_ECHO flag:

 

    #define BSP_DEFAULT_IO_OPEN_MODE                          (void *) (IO_SERIAL_XON_XOFF | IO_SERIAL_TRANSLATION /* | IO_SERIAL_ECHO*/)

 

but after that the shell stops working!!!!

 

I have revised the code in "serl_pol.c" (for polled serial device) but i havent found an easy way to disable serial echo.  

Some ideas??????

 

Thanks in advance!!!!!

Outcomes