AnsweredAssumed Answered

X11 crash on running application 2nd time on custom target bassed on i.MX6S

Question asked by vikash patil on Nov 5, 2014
Latest reply on Nov 6, 2014 by vikash patil

Hi All,

 

I am encountering the following issue on both the release of graphics driver (i.e. 3.10.17-1.0.1 and 3.10.17-1.0.1) on i.MX6s based custom board. I have tried 3.10.17-1.0.0  and 3.10.17-1.0.1 version of recipe's for graphics driver and x ddx driver from daisy branch of meta-fsl-arm and also took the binaries of xorg 1.14.4 after building daisy branch using community-bsp to our custom rootfs.

 

Is this the known issue? Is there any plan to fix this? Could you give some inputs regarding how should I debug and fix if possible?

 

When I run some x11/gles2.0 example first time after starting the X11 (1.14.4), it works fine, however when I try second time I am seeing following errors. In short X11/GLES2.0 application on exit or killing makes X11 unusable and need to restart the X11 to run the application second time. Is this you also observed?

 

 

root@imx6solosabreauto:/opt/

viv_samples/vdk# ./tutorial2_es20 -f 100
systemd[1]: xorg.service: main process exited, code=killed, status=6/ABRT
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0.0"
      after 28 requests (28 known processed) with 0 events remaining.
systemd[1]: Unit xorg.service entered failed state.

 

I also see following in xorg log

 

[    49.212] (**) Option "XkbModel" "pc105"
[    49.213] (**) Option "XkbLayout" "us"
[    49.349] (II) config/udev: Adding drm device (/dev/dri/card0)
[    54.636] (EE)
[    54.636] (EE) Backtrace:
[    54.636] (EE)
[    54.637] (EE) Segmentation fault at address 0x65d24000
[    54.637] (EE)
Fatal server error:
[    54.638] (EE) Caught signal 11 (Segmentation fault). Server aborting
[    54.638] (EE)
[    54.638] (EE)

 


Regards & thanks,
Vikash

Outcomes