AnsweredAssumed Answered

RTC and Sleep-Mode

Question asked by Dominic Ast on Oct 29, 2014
Latest reply on Oct 31, 2014 by Yasuhiko Koumoto

Dear all

 

I just started useing Kinetis L25 Controller with ProcessorExport. Now I face a Problem when I try to use the Sleep-Mode with a running RTC.

 

I have an auto-initializing RTC-Component which is running well.

I have "Very low power modes" and "Low leakage stop mode" allowed in "Cpu/Low power mode Settings/Allowed power modes".

I have all Settings disabled in "Cpu/Low power mode Settings/LLWU Settings/Settings" even "RTC" and "RTC_Seconds"

(See image below)

 

I Switch to the sleep-mode with the following command:

 

Cpu_SetOperationMode(DOM_SLEEP, NULL, NULL);


Without RTC I remain in sleep-mode forever. With the RTC enabled I just wake up again with ERR_OK as return code. I do not really understand this behaviour because RTC and RTC_Seconds are disabled in the LLWU settings. Can anyone give me a hint what is happening here?

 

Thank you for any help .. Dominic


llwu_settings.png

Outcomes