AnsweredAssumed Answered

How to setup Ethernet hardware on the VF61 Vybrid Phytec Cosmic+ Board under Timesys Linux ?

Question asked by Dragan Kujovic on Oct 24, 2014

Respected Colleagues, Timesys Support, Karina Valencia Aguilar,


the Ethernet connection is now on the table.


I can connect VF61 Vybrid Phytec Cosmic+ Board to the Windows PC only trough USB RNDIS.


Connection trough LAN is cold dead (straight cable trough switch on the my LAN network, or crossover cable directly to second LAN connector (alone on that network) on my Windows PC), no matter USB RNDIS is connected to PC or not.


I use a Wireshark application to monitor communication on the LAN, and nothing comes from the Phytec Cosmic+ board.


I have tried to set up IP Address, etc., and tried to setup DHCP on the Phytec Cosmic+ Board under Timesys Linux, but nothing helps.


Do I have to do something in the Timesys Linux ? I have tried both original Timesys Images, and my custom image with apache web server.


In the attachment are boot logs, device list and ifconfig answer from original Timesys image boot, and from mine custom image boot.


Can somebody write, or point to a detailed instruction, how to enable and setup ethernet on the Timesys Linux side to make device connected and visible on the Windows PC side (for example for telnet, Ping, etc.) ?


Thanks in advance.


With best regards,

Dragan Kujovic


Original Attachment has been moved to:

Original Attachment has been moved to: