AnsweredAssumed Answered

TWR-K64 Using SDHC with JTAG port

Question asked by Adrian Rockall on Oct 14, 2014
Latest reply on Jan 15, 2015 by Pedro Augusto Panecatl Salas

Hi,

 

I am trying out various parts of the TWR-K64F120M with a TWR-SER but I can't get the SD card to work. I had it working with the TWR-K60N512 and also the TWR-K60F120M but with the K64 board I get errors.

I have tried using the MQX SDCARD sample as well as my own app but both show the same errors.

 

If I connect via the JTAG debugger then the error appears from the call to: fopen("sdcard:", 0); and "Unable to open SD card device" appears in the console. I think this is due to the SDHC line being shared with the trace lines of the JTAG port so I guess it is not possible to use the SD card while debugging with the JTAG port?

 

If I connect via the Open SDA port then it will get past that but fail at the line: error_code = _io_mfs_install(sdcard_handle, filesystem_name, (_file_size)0); unless I step through it, in which case that works but then it fails at the call to error_code = MFS_Read_device_sector(drive_ptr, BOOT_SECTOR, drive_ptr->DIR_SECTOR_PTR);

 

It is the same SD card that I was using in the TWR-K60N512 board.

 

Does anyone know what J13 does? My board has no pins so I presume it is not required.

 

I can also see that there are a number of zero ohm links connecting the lines to the elevator. Do these need to be removed? (I have tried the board on its own, not connected to the tower, and I see the same problem)

 

I have fitted the 4K7 resistor to R521 and that seems to make the WP work OK.

 

Does anyone know of any other jumpers need to be moved?

 

Has anyone got the SD card working on the TWR-K64120M?

 

Thanks,

Adrian.

Outcomes