AnsweredAssumed Answered

Error building p1020rdb yocto project

Question asked by Binh Ngo on Oct 10, 2014
Latest reply on Oct 16, 2014 by Binh Ngo

Hi,

 

I'm trying to build the following yocto image, fsl-image-full but I got this error:

 

[shadow@orcas]$ bitbake fsl-image-full

WARNING: Host distribution "Unknown" has not been validated with this version of the build system; you may possibly experience unexpected failures. It is recommended that you use a tested distribution.

Loading cache: 100% |###############################################################################################| ETA:  00:00:00

Loaded 2204 entries from dependency cache.

NOTE: Resolving any missing task queue dependencies

 

Build Configuration:

BB_VERSION        = "1.22.0"

BUILD_SYS         = "x86_64-linux"

NATIVELSBSTRING   = "Unknown"

TARGET_SYS        = "powerpc-fsl-linux-gnuspe"

MACHINE           = "p1020rdb"

DISTRO            = "fsl-networking"

DISTRO_VERSION    = "1.6"

TUNE_FEATURES     = "m32 spe ppce500v2"

TARGET_FPU        = "ppc-efd"

meta             

meta-yocto       

meta-yocto-bsp    = "(detachedfromfsl-sdk-v1.6):0d2ce44c2b0f8cc9699e30cca2c24655be89d58b"

meta-fsl-ppc      = "(detachedfromfsl-sdk-v1.6):6cf59d9de63a9fc5f8942c0d10c622898f4315ce"

meta-fsl-ppc-toolchain = "(detachedfromfsl-sdk-v1.6):a546e42f86e7d57de19e27907365d170b13fc18f"

meta-fsl-networking

meta-fsl-networking = "(detachedfrom8dec9c6):8dec9c690188cce5305ef5055f91e5cfa35c63f4"

meta-virtualization

meta-virtualization = "(detachedfromfsl-sdk-v1.6):8044073f63a0d99541a43ac5f2f6d789f94c7c7c"

meta-oe          

meta-networking  

meta-webserver   

meta-ruby        

meta-filesystems  = "(detachedfromfsl-sdk-v1.6):b86007f742a1b829ccc8d76e485bb3f789cefaa4"

meta-java         = "(detachedfromfsl-sdk-v1.6):d01f7d39e513790ddce20e6724723722119a3700"

meta-openstack   

meta-openstack-compute-deploy

meta-openstack-controller-deploy

meta-openstack-qemu = "(detachedfromfsl-sdk-v1.6):f627404399a134672e0b5e26a0d9b794a6f8adf4"

 

NOTE: Preparing runqueue

NOTE: Executing SetScene Tasks

NOTE: Executing RunQueue Tasks

WARNING: Failed to fetch URL git://git.am.freescale.net/gitolite/sdk/hyperrelay.git, attempting MIRRORS if available

WARNING: Failed to fetch URL git://git.am.freescale.net/gitolite/libppc.git, attempting MIRRORS if available

ERROR: Fetcher failure: Fetch command failed with exit code 128, output:

Cloning into bare repository '/opt/fsl/yocto/build_p1020rdb_release/../sources/git2/git.am.freescale.net.gitolite.sdk.hyperrelay.git'...

2014/10/09 15:21:32 socat[29235] E CONNECT git.am.freescale.net:9418: Service Unavailable

fatal: Could not read from remote repository.

 

Please make sure you have the correct access rights

and the repository exists.

 

ERROR: Function failed: Fetcher failure for URL: 'git://git.am.freescale.net/gitolite/sdk/hyperrelay.git'. Unable to fetch URL from any source.

ERROR: Logfile of failure stored in: /opt/fsl/build_p1020rdb_release/tmp/work/ppce500v2-fsl-linux-gnuspe/hyperrelay/git-r0/temp/log.do_fetch.29205

ERROR: Task 527 (/opt/fsl/meta-fsl-networking/recipes-extended/hyperrelay/hyperrelay_git.bb, do_fetch) failed with exit code '1'

ERROR: Fetcher failure: Fetch command failed with exit code 128, output:

Cloning into bare repository '/opt/fsl/yocto/build_p1020rdb_release/../sources/git2/git.am.freescale.net.gitolite.libppc.git'...

2014/10/09 15:21:32 socat[29232] E CONNECT git.am.freescale.net:9418: Service Unavailable

fatal: Could not read from remote repository.

 

Please make sure you have the correct access rights

and the repository exists.

 

ERROR: Function failed: Fetcher failure for URL: 'git://git.am.freescale.net/gitolite/libppc.git'. Unable to fetch URL from any source.

ERROR: Logfile of failure stored in: /opt/fsl/build_p1020rdb_release/tmp/work/ppce500v2-fsl-linux-gnuspe/libppc/git-r0/temp/log.do_fetch.29203

ERROR: Task 751 (/opt/fsl/meta-fsl-networking/recipes-bsp/libppc/libppc_git.bb, do_fetch) failed with exit code '1'

NOTE: Tasks Summary: Attempted 838 tasks of which 798 didn't need to be rerun and 2 failed.

Waiting for 0 running tasks to finish:

 

Summary: 2 tasks failed:

  /opt/fsl/meta-fsl-networking/recipes-extended/hyperrelay/hyperrelay_git.bb, do_fetch

  /opt/fsl/meta-fsl-networking/recipes-bsp/libppc/libppc_git.bb, do_fetch

Summary: There were 3 WARNING messages shown.

Summary: There were 4 ERROR messages shown, returning a non-zero exit code.

 

The source sdk iso does not contain the souces for these packages.

The only file it has in the sources directory are:

 

git2_git.am.freescale.net.gitolite.sdk.hyperrelay.git.tar.gz

git2_git.am.freescale.net.gitolite.sdk.hyperrelay.git.tar.gz.done

git2_git.am.freescale.net.gitolite.libppc.git.tar.gz

git2_git.am.freescale.net.gitolite.libppc.git.tar.gz.done

 

This is from the source sdk iso: QorIQ-SDK-V1.6-SOURCE-20140619-yocto.iso

 

Anyone know where I can get the source to libppc and hyperrelay?

I believe these are the only missing packages for a successful build.

 

Any help is appreciated.

 

Thanks,

 

- binh

Outcomes