AnsweredAssumed Answered

PE Micro Multilink Universal Rev A not working on K64 TWR board

Question asked by John Baker on Sep 26, 2014
Latest reply on Oct 1, 2014 by John Baker

I originally posted this on PE Micro's forum but received a reply from another engineer here that it works fine on our K60 board.  He cannot get it to work on the K64 TWR board either.  We keep getting the error, "Cannot enter background mode"  (See original post below):

 

Thanks,

 

John Baker

AVG

 

  • I am using a Multilink Universal Rev A (PE5655063) plugged into the JTAG connector of a TWR-K64F120M board. KDS Ver. 1.1.1 debugger is configured properly but I get the following error:


    P&E GDB Server, Version 5.07.00.00
    Copyright 2014, P&E Microcomputer Systems Inc, All rights reserved

    Loading library C:\Freescale\KDS_1.1.1\eclipse\plugins\com.pemicro.debug.gdbjtag.pne_1.1.2.201408071632\win32\gdi\unit_ngs_arm_internal.dll ... Done.

    Command line arguments: -device=K64FN1M0M12 -startserver -serverport=7224 -interface=USBMULTILINK -speed=5000 -port=USB1 -USE_CYCLONEPRO_RELAYS=0 -FORCE_MASS_ERASE=0
    Device selected is k64fn1m0m12
    User Specified Hardware Selection : Interface=USBMULTILINK and Port=USB1
    Connecting to target.
    P&E Interface detected - Flash Version 6.10

    Can not enter background mode  .
    Comment #1 John B. - September 16, 2014 - 02:42 PM (14:42 hours)



    Comments

  • KDS version 1.1.1 is able to debug a K60 tower board with the exact same Universal Multilink that was referenced in the previous comment, so the problem has to do with the K64 tower board (or with K64 in general). Does anyone have any experience/comments regarding using KDS with the Universal Multilink to target the K64?
    Comment #2 Brian H. - September 26, 2014 - 01:01 PM (13:01 hours)

Outcomes