AnsweredAssumed Answered

Building Image With Yocto - Wrong Kernel Version

Question asked by flohg on Sep 24, 2014
Latest reply on Sep 30, 2014 by gusarambula

Hello!

 

I am currently trying to build a image for a imx6Q Board. So far I have followed two tutorials

https://community.freescale.com/docs/DOC-94849

and the

Freescale Yocto Project's User Guide

 

Everything works fine.

 

The problem started when I tried to attach a USB Camera to the board. The board recognizes it, but just as:

usb 1-1: new high-speed USB device number 3 using ci_hdrc

 

After some google-using I knew I had to load (or at least try to load) the modules "uvcvideo.ko" and/or "gspca_main.ko".

So I tried this on the board

insmod uvcvideo.ko

Which lead to the output:

uvcvideo: disagrees about version of symbol module_layout

and

insmod: ERROR: could not insert module uvcvideo.ko: Invalid module format

 

Ok, the modules where build against a different kernel version - checking the board kernel version (uname -r): 3.16.0-rc3

But the modules reside in the directory /lib/modules/3.10.17-1.0.1_ga+gdac46dc

 

So my question is, where does this kernel 3.16 come from?

At the moment I actually do not care what kernel version I use, I just want to be able to use the modules I build.

 

On a side note: If start menuconfig for virtual/kernel I am able to configure the kernel for 3.10.17.

 

Maybe someone can help me or point me in the right direction.

 

Best Regards,

Florian

Outcomes