AnsweredAssumed Answered

[Technical Issue] kernel hangs at Galcore and VPU Issue

Question asked by Elliott Yang on Sep 17, 2014
Latest reply on Jun 12, 2015 by huang zhanfei

Hi All

 

We are running at i.MX6 Dual Lite soc and our own board, the linux kernel version is 3.10.17(yocto).

 

When we start up the system, it would stop.

 

……

rtl8192cu: Board Type 0

rtlwifi: rx_max_size 15360, rx_urb_num 8, in_ep 1

rtl8192cu: Loading firmware rtlwifi/rtl8192cufw.bin

Galcore version 4.6.9.9754  <-----------stop at here

 

In order to fix the problem, I found an article that can fix my problem,

https://community.freescale.com/message/424352#424352

 

They changed in file imx6qdl-sabresd.dtsi as follows.

 

&cpu0 {

arm-supply = <&reg_arm>;

soc-supply = <&reg_soc>;

pu-supply = <&reg_pu>; /* use pu_dummy if VDDSOC share with VDDPU */

};

 

&gpc {

fsl,ldo-bypass = <0>; /* use ldo-bypass, u-boot will check it and configure */

fsl,wdog-reset = <1>; /* watchdog select of reset source */

pu-supply = <&reg_pu>; /* ldo-bypass:use pu_dummy if VDDSOC share with VDDPU */

};

 

&gpu {

pu-supply = <&reg_pu>; /* ldo-bypass:use pu_dummy if VDDSOC share with VDDPU */

};

 

&vpu {

pu-supply = <&reg_pu>; /* ldo-bypass:use pu_dummy if VDDSOC share with VDDPU */

};

 

But now, we found another issue, we couldn’t use GStreamer to streaming video via VPU codec.(If I don’t use VPU codec, GStreamer is work well.)

Here is my command:

gst-launch-0.10 mfw_v4lsrc ! video/x-raw-yuv,width=640,height=480 ! vpuenc codec=6 ! rtph264pay ! udpsink host=192.168.8.123 port=5000

 

and it’s the error massage:

MFW_GST_V4LSRC_PLUGIN 3.0.11 build on Aug 20 2014 13:45:43.

Setting pipeline to PAUSED ...

ERROR: Pipeline doesn't want to pause.

Setting pipeline to NULL ...

Freeing pipeline ...

 

My question is what’s the different about “pu_dummy” and “reg_pu” ?

Does anyone has any idea about this issue?

 

BTW, if we modify the device tree as the article, I can’t get 1.2V at VDDPU, it’s 0.095V.

 

Thanks a lot,

Outcomes