AnsweredAssumed Answered

How to disable NAND device in U-Boot?

Question asked by Jack Blather on Sep 15, 2014
Latest reply on Jan 13, 2015 by Jack Blather

I have u-boot running on the VF610TWR board. It boots from the SD Card. I want to disable it looking for the MT29F2G16ABA NAND chip. How does one do that?

 

I have a new board based on the vf610twr design (SD Card boot), but it doesn't have NAND flash. When I try to boot this new board, I get this from u-boot:

 

U-Boot 2013.07 (Aug 14 2014 - 07:45:53)

 

CPU:   Freescale Vybrid 600 family rev1.2 at 396 MHz

Reset cause: POR

Board: TWR-VF65GS10

DRAM:  128 MiB

WARNING: Caches not enabled

NAND:

 

It *hangs* on the "NAND:" line. Since I don't have flash on this new board, I need to disable searching for it. Boot is from SD Card.

 

I'm going to try adding this line in the u-boot-2013.07/u-boot-2013.07/board/freescale/vf610twr\imximage.cfg file:

 

#unset CONFIG_CMD_NAND

 

but I have a feeling it isn't going to help...

 

Thanks

Outcomes