AnsweredAssumed Answered

Building X-11 image on i.MX 6Quad Sabre-SD

Question asked by Philippe Balleydier on Sep 15, 2014
Latest reply on Feb 26, 2015 by Philippe Balleydier

Hi

 

i'm following the "Freescale Yocto project User's guide" to build the image x11 on the i.XM 6quad sabre-sd but i'm having issues

I had multiple issues during the "bitbake fsl-image-x11" command that i managed to solved.

When i'm finally reaching the eand (task 4721/4748) i get this error multiple times:

 

ERROR: QA Issue: non debug package contains .debug directory: qt4-examples path /work/imx6qsabresd-poky-linux-gnueabi/qt4-x11-free/1_4.8.5-r0/packages-split/qt4-examples/usr/bin/qt4/examples/declarative/cppextensions/referenceexamples/extended/.obj/release-shared/.debug/qrc_extended.o

 

and at the end of it:

 

ERROR: QA run found fatal errors. Please consider fixing them.

ERROR: Function failed: do_package_qa

ERROR: Logfile of failure stored in: /mnt/Ubuntu/fsl-release-bsp/build-x11/tmp/work/imx6qsabresd-poky-linux-gnueabi/qt4-x11-free/1_4.8.5-r0/temp/log.do_package.2921

ERROR: Task 515 (/mnt/Ubuntu/fsl-release-bsp/sources/poky/meta/recipes-qt/qt4/qt4-x11-free_4.8.5.bb, do_package) failed with exit code '1'

 

I tried removing all the .o files concerned by hand, but this didn't solve the problem since they are created everytime.

I also tried some solutions found on the internet, like adding some lines in the bb files but this didn't work either.

 

It's been a week i'm trying to make this work, and i'm all out of ideas.

 

Thx by advance.

 

Ce message a été modifié par : Philippe Balleydier

Outcomes