AnsweredAssumed Answered

Bitbake does not generate rootfs

Question asked by maxa jean on Sep 14, 2014

I'm using open embedded to cross compile a linux distribution for my imx. I followed the steps cited below to generate the image.

 

  1. git clone git://git.eukrea.fr/distro/setup-scripts.git -b distro-master

It creates a folder called setup-scripts

  • cd setup-scripts/
  • ./oebb.sh config distro-cth
  • source .oe/environment-oecore
  • export MACHINE=nitrogen6x
  • bitbake cth-base-image

This last step is actually supposed to generate the kernel image (uImage) and the rootfs, but for some reasons, it does not. Here is the output of this last command.

( I copy the full output in the attachment)

> bitbake cth-base-image

WARNING: Duplicate inclusion for /home/maxa/setup-scripts/sources/openembedded-core/meta/conf/distro/include/tclibc-eglibc.inc in /home/maxa/setup-scripts/sources/openembedded-core/meta/conf/distro/defaultsetup.conf

Loading cache: 100% |###########################################################################################################| ETA:  00:00:00

Loaded 1836 entries from dependency cache.

NOTE: Resolving any missing task queue dependencies

NOTE: multiple providers are available for jpeg-native (jpeg-native, libjpeg-turbo-native)

NOTE: consider defining a PREFERRED_PROVIDER entry to match jpeg-native

 

 

Build Configuration:

BB_VERSION        = "1.20.0"

BUILD_SYS         = "x86_64-linux"

NATIVELSBSTRING   = "Ubuntu-14.04"

TARGET_SYS        = "arm-oe-linux-gnueabi"

MACHINE           = "nitrogen6x"

DISTRO            = "defaultsetup"

DISTRO_VERSION    = "oe-core.0"

TUNE_FEATURES     = "armv7a vfp neon callconvention-hard cortexa9"

TARGET_FPU        = "vfp-neon"

meta-oe          

toolchain-layer  

meta-initramfs   

meta-networking  

meta-webserver    = "dora:ee173678383683e972c7d4d6f0ef5790bfa50274"

meta-fsl-demos    = "dora:5a12677ad000a926d23c444266722a778ea228a7"

meta-fsl-arm      = "dora:5fdb620c09df11e70434092f675c891e0ba84108"

meta-fsl-arm-extra = "dora:375f89b70655be2a17bbde36de6adb4e4a5a6975"

meta-delair       = "master:f28bc4ddfe962f508ccb60637a34ad2ac027cecc"

meta              = "dora:5c51dd2e9bab54013652475888554bc4660dcff3"

 

 

NOTE: Preparing runqueue

NOTE: Executing SetScene Tasks

WARNING: Duplicate inclusion for /home/maxa/setup-scripts/sources/openembedded-core/meta/conf/distro/include/tcmode-default.inc in /home/maxa/setup-scripts/sources/openembedded-core/meta/conf/distro/defaultsetup.conf

WARNING: Duplicate inclusion for /home/maxa/setup-scripts/sources/openembedded-core/meta/conf/distro/include/as-needed.inc in /home/maxa/setup-scripts/sources/openembedded-core/meta/conf/distro/include/tcmode-default.inc

WARNING: Duplicate inclusion for /home/maxa/setup-scripts/sources/openembedded-core/meta/conf/distro/include/tclibc-eglibc.inc in /home/maxa/setup-scripts/sources/openembedded-core/meta/conf/distro/defaultsetup.conf

NOTE: Executing RunQueue Tasks

WARNING: Failed to fetch URL ftp://kermit.columbia.edu/kermit/archives/cku301.tar.gz;subdir=ckermit-301, attempting MIRRORS if available

ERROR: Fetcher failure: Fetch command failed with exit code 4, no output

ERROR: Function failed: Fetcher failure for URL: 'ftp://kermit.columbia.edu/kermit/archives/cku301.tar.gz;subdir=ckermit-301'. Unable to fetch URL from any source.

ERROR: Logfile of failure stored in: /home/maxa/setup-scripts/build/tmp-defaultsetup-eglibc-eglibc/work/cortexa9hf-vfp-neon-oe-linux-gnueabi/ckermit/301-r0/temp/log.do_fetch.8401

ERROR: Task 596 (/home/maxa/setup-scripts/sources/meta-openembedded/meta-oe/recipes-support/ckermit/ckermit_301.bb, do_fetch) failed with exit code '1'

NOTE: Tasks Summary: Attempted 5399 tasks of which 5386 didn't need to be rerun and 1 failed.

Waiting for 0 running tasks to finish:

 

Summary: 1 task failed:

  /home/maxa/setup-scripts/sources/meta-openembedded/meta-oe/recipes-support/ckermit/ckermit_301.bb, do_fetch

Summary: There were 25 WARNING messages shown.

Summary: There were 2 ERROR messages shown, returning a non-zero exit code.


It actually showed that something went bad and may be that is the reason why when I check the result in /tmp-defaultsetup-eglibc-eglibc/deploy/images/nitrogen6x/

I only got the uImage and the rootfs is missing.


So, I think, If I can solve the "ERROR: Fetcher failure" problems, may be I can generate both the uImage and the rootfs.

Can anyone suggest a solution ?

I've tried to resolve this a couple weeks now, and I really cannot figure out a way out of this.

Thanks


best regards




Original Attachment has been moved to: output.zip

Outcomes