AnsweredAssumed Answered

LVDS display is not working in IMX custom board

Question asked by Ashok p on Sep 11, 2014
Latest reply on Sep 17, 2014 by alejandrolozano

Hi All,

 

I am using IMX6 based custom board and running kitkat from freescale. The kernel version is 3.0.35.

 

The HDMI and LCD displays are working fine  but LVDS display is not working fine. Please let me know if any issues in the code changes.

 

Below i copied the fb structure for your reference. Also attached my board file for your reference

 

static struct ipuv3_fb_platform_data sabresd_fb_data[] = {

        { /*fb0*/

        .disp_dev = "hdmi",

        .interface_pix_fmt = IPU_PIX_FMT_RGB24,

        .mode_str = "1920x1080M@60",

        .default_bpp = 24,

        .int_clk = false,

        .late_init = false,

        }, {

        .disp_dev = "lcd",

        .interface_pix_fmt = IPU_PIX_FMT_RGB24,

        .mode_str = "CLAA-WVGA",

        .default_bpp = 24,

        .int_clk = false,

        .late_init = false,

        }, {

        .disp_dev = "ldb",

        .interface_pix_fmt = IPU_PIX_FMT_RGB666,

//        .mode_str = "LDB-XGA",

        .default_bpp = 24,

        .int_clk = false,

        .late_init = false,

        },

};

 

 

 

static struct fsl_mxc_ldb_platform_data ldb_data = {

        .ipu_id = 0,   // ASHOK

        .disp_id = 0,

        .ext_ref = 1,

        .mode = LDB_SEP1,

        .sec_ipu_id = 0,

        .sec_disp_id = 0,

};

 

Thanks,

P.Ashok

Original Attachment has been moved to: board-mx6q_sabresd.c.zip

Outcomes