AnsweredAssumed Answered

USBDM always busy in FRDM-K64F

Question asked by Artur Silva on Sep 5, 2014
Latest reply on Jan 14, 2016 by Artur Silva

Hello everyone,

 

I'm having some troubles with USBDM. I recently got two FRDM K64F, had some problem with KDS and Codewarrior to run these babies but I finally made it using Segger openSda, PEmicro openSDA and cmsis-dap.
So the problem starts after I build my own PCB with a Kinetis uC and tried to debbug it. Segger and PEmicro openSDA are blocked for other devices.

 

I was not able to debbug another board besides the freedom, so someone told me to try USBDM.

 

I followed the steps, installed the drivers, the software and uploaded the USBDM firmware to both of the frdm k64f.
My windows was able to find and install the devices, but I can't run it in any software. The USBDM firmware upgrade software say that my device can't be found because it always busy.

 

I tried the same procedure with a FRDM KL25 that I own, but it is my windows that can't recognize the device. It always find the device as unknown.

 

Ps.: I'm using the latest USBDM that I found in sourceforge.

 

Anyone have an ideia to solve this? Or have any ideia how to debbug another board using the Freedom boards?

 

Regards,
Artur

Outcomes