AnsweredAssumed Answered

IMX6S clock halts for 24 minutes

Question asked by Bastiaan de Nooij on Sep 2, 2014
Latest reply on Dec 16, 2016 by Federico Loda

Hello all,

we are developing an embedded system around a technexion EDM board based on the IMX6s processor.

http://www.technexion.com/index.php/products/edm/edm-som/edm1-cf-imx6

We use this module with an lvds screen, 2 uarts (1 for console, 1 for serial touch), spi1 and spi2

Using yocto 1.5 and a slightly modified wandboard-solo environment, we created a system with kernel 3.0.35

 

Now we observe some strange behavior. At very random times (say once or twice every week), the system 'hangs', there is no communication over the spi buses and the screen is not updated)

After 24 minutes (always 24), the system resumes as if nothing happened and the system clock at this point is 24 minutes behind. (i.o.w. it has been halted for 24 minutes)

 

It has also been observed that using the serial touchscreen (connected to /dev/ttymxc1) "awakens" the system when it is in it's 24 minute sleep period.

It looks like the CPU is in some kind of WFI mode, but I am unable to confirm this.

 

So far we have been unsuccessful in reliably reproducing the issue or even increase the frequency of it's occurrence.

I am wondering if the issue mentioned here:iMX6 / v3.0.35 / system hang-up problem could be related, but I am not sure.

 

We are testing the new kernel (3.10.17) now, but I would like to know the root cause of the observed problem.

 

Does anyone have a clue?

 

Het bericht is bewerkt door: Bastiaan de Nooij

 

After migrating to the 3.10.17 kernel, the problem no longer occurs....

Outcomes