AnsweredAssumed Answered

Webserver MQX4.1.0.1 TWRK70F120M doesn't work

Question asked by Mirko Fortunato on Aug 17, 2014
Latest reply on Aug 19, 2014 by David E Seymour

Good morning,

I use MQX4.1 patched 1 and CW10.4, the microcontroller is K70 and the hardware is the TWRK70F120M.

I want to test the webserver.

I changed  BSP_DEFAULT_MAX_MSGPOOLS in the file twrk70f120m.h from 2 to 5, as suggested in the demo "web_hvac".

I compiled all the library in debug mode. It is strange but I got some warning, see psp_warning.jpg.

I compiled the demo "web_hvac" before in SRAMData_Debug mode and then in DDRData_Debug mode.

I flshed the micro and then I started the demo "web_hvac" using the debugger.

The setting IP of the board is the default:IP=192.168.1.202 - mask=255.255.255.0.

The setting of the PC is: IP=192.168.1.100 - mask=255.255.255.0.

I connected directly the PC with the TWRK70 with an Ethernet cable which is OK.

I tried to communicate by Ethernet but:

- the "ping" command from DOS shell of the PC failed

- the webserver of TWRK70 didn't work, I tried with Mozila Firefox and with Google Chrome to ask the home page but there was no connection

The initialization of RTCS task is OK, I hadn't any error in the task (see "Task summary.jpg" and also viewed by the debugger step by step).

In conclusion the webserver is not working!!! There is no connection by Ethernet, even if it is the demo software and the hardware is the TWRK70.

Why? Can you say me which is the error?

 

Thank you

Best Regards

Mirko

Attachments

Outcomes