AnsweredAssumed Answered

Error: #warning "EWL support for C99 is not enabled"

Question asked by Mirko Fortunato on Jul 31, 2014
Latest reply on Nov 3, 2016 by Marceli Firlej

Good morning,

I use micro MCF52255 and I want porting my project compiled in CW10.2 with MQX3.8.1 in a project compiled in CW10.6 with MQX4.1.0 to try the new webserver.

I can't compile the project because I get the following error:

 

"C:\Freescale\CW MCU v10.6\eclipse\../MCU/ColdFire_Tools/Command_Line_Tools/mwccmcf" @@"Source\HVAC/global_1.args" -o "Source\HVAC\global_c.obj" "..\..\source\global.c"

Source\HVAC/global_1.args : -sym full -msgstyle parseable -proc 52255 -lavender model=ewl ,print=int_FP ,scan=int_FP ,io=buffered -c -nostdinc -nosyspath -enc ascii -i "C:/Progetti/MQXETH/lib/eth.cw10/bsp" -i "C:/Progetti/MQXETH/lib/eth.cw10/usb/host" -i "C:/Progetti/MQXETH/lib/eth.cw10/usb" -i "C:/Progetti/MQXETH/lib/eth.cw10/shell" -i "C:/Progetti/MQXETH/lib/eth.cw10/mfs" -i "C:/Progetti/MQXETH/lib/eth.cw10/rtcs" -i "C:/Progetti/MQXETH/lib/eth.cw10" -i "C:/Progetti/MQXETH/lib/eth.cw10/psp" -ir "C:/Progetti/STUSNP/stusnp/build" -ir "C:/Progetti/STUSNP/stusnp" -ir "C:/Progetti/MQXETH/usb/host/source/classes/common" -I- -ir "C:/Freescale/CW MCU v10.6/MCU" -prefix "C:/Progetti/STUSNP/stusnp/build/Int Flash Debug.prefix" -warn unusedvar -warn extracomma -opt level=1 -opt space -ipa off -inline on -align coldfire -model farCode -model farData -fp soft -a6 -nocoloring -noscheduling -nopeephole -sdata 0 -requireprotos -lang c99 -Cpp_Exceptions off -RTTI off -enum int -char unsigned -str nopool -str reuse 

../MCU/ColdFire_Tools/Command_Line_Tools/mwccmcf|Compiler|Warning

(C:\Freescale\CW MCU v10.6\MCU\ARM_EABI_Support\ewl\EWL_C\include\stdbool.h|20|1|0|387|0)

= #warning "EWL support for C99 is not enabled" 

 

I saw that all the macro for defining the variables are changed (example uint32_t) and I try to correct it without good result.

I enable the EWL e C99 language, see figures Language_Setting.jpg and Set_ewl.jpg, no good result.

The error compile doesn't recognaize the new type "bool", too.

Do you have any idea?

Set_ewl.jpgLanguage_Settings.jpg

Thank you

Best Regards

Mirko

Outcomes