AnsweredAssumed Answered

imx6q doesn't work in 1G, Could be the ripples of vddarm_cap?

Question asked by chuanyan yin on Jul 25, 2014

Hi,

 

I have a custom board, the soc version is MCIMX6Q5EYM10AC, TO1.2, the software is jb4.3 GA(12/19/2013 released), I use dcdc converter (RT8070) to supply vddarm. The VDDARM_IN is 1.35V and the VDDARM_CAP is 1.225V. When I go to the android UI and click the settings,  the kernel crash ramdonly, It print oops errors. The kernel's log is different every time.I Search the  issue in the this community, patch the the some patches and got the the same result, so I change VDDARM_IN to 1.4V, chagne VDDARM_CAP to 1.25V,  see the code below:

.pll_rate = 996000000,

 

         .cpu_rate = 996000000,

         .cpu_podf = 0,

         .pu_voltage = 1250000,

         .soc_voltage = 1250000,

         .cpu_voltage = 1250000,},

 

I have used performance governor to disable dvfs already.

 

the system don't crash when I click Settings of Android, and it seems to be more stable. But when I run the display_tester_3.8.3.apk to  to check the lcd, the system crash again.   And this apk can run normally in my sabrelite board. When I add arm_freq=800 in the bootargs of u-boot, every thing is fine. Is it caused by the VDDARM_CAP's ripples? In my custom board, the trace length of  22uf bulk capacitor is more than 250 mils from the vddarm_cap pad, and the trace width is 5mil.

 

                       VOLTAGE    RIPPLES

VDDARM_IN     1.4V            <=80mv

VDDARM_CAP  1.25V          >=100mv

Original Attachment has been moved to: display_tester_3.8.3.apk.zip

Outcomes