AnsweredAssumed Answered

X11/GLESv2/LayerManager bring up on Wandboard (i.MX6 Solo) help

Question asked by vikash patil on Jul 23, 2014
Latest reply on Jul 25, 2014 by vikash patil

Dear All,

 

I am able to start the X11 (version 1.12.3) and run demos from "fsl-gpu-sdk-1.1" on Wandboard Solo(i.e. i.MX6 Solo). I have built the graphics driver, xorg driver  and fsl-gpu-sdk from daisy branch of meat-fsl-arm from Freescale git(https://github.com/Freescale) and copied to custom filesystem which has Xorg version 1.12.3.

 

Platform: Wandboard

Kernel: 3.10.17-1.0.0-wandboard-02434-g7eb9930 #5 SMP PREEMPT Wed Jul 23 11:45:33 IST 2014 armv7l GNU/Linux

GPU Driver: gpu-viv-bin-mx6q-3.10.17-1.0.0-hfp

Xorg Driver: xserver-xorg-video-imx-viv-3.10.17-1.0.0

Vivante SDK demo: fsl-gpu-sdk-1.1

Display: HDMI with following mode

mode "1280x720-60"

        # D: 74.250 MHz, H: 45.000 kHz, V: 60.000 Hz

        geometry 1280 720 1280 720 24

        timings 13468 220 110 20 5 40 5

        accel false

        rgba 8/16,8/8,8/0,0/0

endmode

 

Attached here:

xorg conf: xorg-imx6.conf

log of Xorg:Xorg.0.log

log of layermanaher: LayerManagerService.log

 

I would like to understand and fix following issues which I am facing currently.

 

1) I am seeing following error in Xorg log after starting X11, How can I fix this and what is the significance of it? Or Is it ok to live with it?

[  1136.588] (EE) VIVANTE(0): fb memory is not big enough to hold shadow buffer!

 

2) I can run demos from fsl-gpu-sdk-1.1 and see on display but when I run demos from /opt/viv_samples/vdk from package "gpu-viv-bin-mx6q-3.10.17-1.0.0-hfp" can't see anything on display. How can I run these demos and see on display?

 

3) I would like to run GENIVI LayerManager on above setup (i.e. X11 and GLESv2). I have build the layer manager 0.9.9 and copied to filesystem. However I can start LayermanagerService and EGLX11MockNavigation but can't see anything on display and from the log it seems it is running?

 

Could anyone suggest me what is going wrong here? or Is there any limitation running this?

 

I start X11 and layer manager using following commnds:

 

# /usr/bin/Xorg -config /etc/X11/xorg-imx6.conf -retro -quiet -ignoreABI &

# export DISPLAY=:0.0

# LayerManagerService -c4 -f4 -w1280 -h720 &

# EGLX11MockNavigation &

 

Waiting for experts comments/suggestions. Thanks for your time for reading this.

 

Thanks & Regards,

Vikas

Original Attachment has been moved to: Xorg.0.log.zip

Original Attachment has been moved to: xorg-imx6.conf.zip

Original Attachment has been moved to: LayerManagerService.log.zip

Outcomes