AnsweredAssumed Answered

Imx6solo: SD boot issue

Question asked by prashant dalmia on Jul 21, 2014
Latest reply on May 16, 2015 by Lalit Kumar

I am using custom imx6 solo board.


SD boot Issue Details:
=================

BMOD[1:0]= 10- Internal boot
1. Not booting from SD card
2. JTAG also not connected.

BMOd[1:0]= 00 - boot from fuses.
1. JTAG connected if Micro SD Card NOT connected.
2. Boots from SD if JTAG NOT connected.(fuses are at default setting)


Boot logs:

=========

U-Boot 2009.08 (Jul 19 2014 - 19:41:32)

 

CPU: Freescale i.MX6 family TO1.2 at 792 MHz

Thermal sensor with ratio = 182

Temperature:   41 C, calibration data 0x57e4c47d

mx6q pll1: 792MHz

mx6q pll2: 528MHz

mx6q pll3: 480MHz

mx6q pll8: 50MHz

ipg clock     : 66000000Hz

ipg per clock : 66000000Hz

uart clock    : 80000000Hz

cspi clock    : 60000000Hz

ahb clock     : 132000000Hz

axi clock   : 198000000Hz

emi_slow clock: 99000000Hz

ddr clock     : 396000000Hz

usdhc1 clock  : 198000000Hz

usdhc2 clock  : 198000000Hz

usdhc3 clock  : 198000000Hz

usdhc4 clock  : 198000000Hz

nfc clock     : 24000000Hz

Board: i.MX6DL/Solo-ZENBOX: unknown-board Board: 0x61012 [POR]

Boot Device: NOR

I2C:   ready

DRAM:   1 GB

MMC:   FSL_USDHC: 0

*** Warning - bad CRC or MMC, using default environment

 

In:    serial

Out:   serial

Err:   serial

Net:   got MAC address from IIM: 00:00:00:00:00:00

FEC0 [PRIME]

Hit any key to stop autoboot:  0

MX6SOLO SABREAUTO U-Boot >

 

Fuses Dump:
===========

 

MX6SOLO SABREAUTO U-Boot > imxotp read 0
Reading fuse at index: 0x0
Fuse at (index: 0x0) value: 0x20220002
MX6SOLO SABREAUTO U-Boot > imxotp read 5
Reading fuse at index: 0x5
Fuse at (index: 0x5) value: 0x0
MX6SOLO SABREAUTO U-Boot > imxotp read 6
Reading fuse at index: 0x6
Fuse at (index: 0x6) value: 0x0

SRC registers Dump
=================

 

MX6SOLO SABREAUTO U-Boot > md 0x20d8000

020d8000: 00000521 00000000 00000001 00000000    !...............

020d8010: 00000000 00000000 0000001f 08000001    ................

020d8020: 00000000 00000000 00000000 00000000    ................

020d8030: 00000000 00000000 00000000 00000000    ................

020d8040: 00000000 00000000 00000000 00000000    ................

020d8050: 00000000 00000000 00000000 00000000    ................

020d8060: 00000000 00000000 00000000 00000000    ................

020d8070: 00000000 00000000 00000000 00000000    ................

020d8080: 00000000 00000000 00000000 00000000    ................

020d8090: 00000000 00000000 00000000 00000000    ................

020d80a0: 00000000 00000000 00000000 00000000    ................

020d80b0: 00000000 00000000 00000000 00000000    ................

020d80c0: 00000000 00000000 00000000 00000000    ................

020d80d0: 00000000 00000000 00000000 00000000    ................

020d80e0: 00000000 00000000 00000000 00000000    ................

020d80f0: 00000000 00000000 00000000 00000000    ................

 

Please help to identify the issue how it is booting in Bmod[1:0]= 00  when fuses are not blown and not booting in internal boot mode.

Outcomes