AnsweredAssumed Answered

i.mx6 SD Card boot 16GB

Question asked by steve rathjen on Jul 10, 2014
Latest reply on Oct 17, 2014 by steve rathjen

Hello all,

 

I've got a custom board made very similar to the Sabre-SD.  I was planning to boot from 16GB microSD Card on custom board.  This is no problem on Sabre-SD, but only 8GB works on my custom board.  U-boot loads, but fails to find uImage and/or the partition uImage is on.

 

I have a 4GB, 8GB, 16GB Class 4 microSD and one 16GB HC-I (class 10?) card.  All work in Sabre-SD - only the 8GB works in my custom board.  It is the only 8GB card I have atm... I've ordered more.

 

Is 8GB coded anywhere?  u-boot, perhaps?  BTFUSE?  How is it possible that only an 8GB works (and works well - no intermittent problems) in my custom board while all cards work in the Sabre-Sd board?

 

Building image using Yocto.  Custom u-boot 2013.10.  Linux 3.0.35.r38.  fsl-image-gui.  sudo dd if=tmp/deploy/images/imx6qsabresd/fsl-image-gui-imx6qsabresd.sdcard of=/dev/sdg bs=1M (tried without bs=1M).  I also tried using MFGtool to write the SD cards and that had the same results - custom board could only write to the 8GB.

 

Thanks for any ideas!

Steve

Outcomes