AnsweredAssumed Answered

Can't turn off NMI using Processor Expert and KE06

Question asked by David Sherman on Jul 10, 2014
Latest reply on Jul 11, 2014 by David Sherman

Having a bit of a problem, for which I've logged a service request.  Thought I'd share so if anybody else is trying to use SPI0 module with the default PORTB pins, they'll know whats wrong.  Stumbled onto the fact that trying to use the SPI0 module creates a problem if the NMI is still enabled in SIM SOPT0.  It defaults to on, and it does not automatically turn off if the SPI module is enabled.  NMI shares the PORTB4 pin with SPI0_MISO.  Since I'm using MQX, Processor Expert has the NMI enabled by default.  Trouble is, it's a write once bit.  It turns out if I uncheck the NMI checkbox in the CPU configuration, it is still defined, so I've had to modify cpu_init.c to make sure it disables NMI.

Outcomes