AnsweredAssumed Answered

Problem with USB Multilink Interface (yellow light always ON) detecting MCU MC9S08AW16

Question asked by Guillaume Beaufort Samson on Jul 10, 2014
Latest reply on Jul 28, 2014 by rickli

Hi there, I’m using the USB-ML-12E programmer to program a chip MC9S08AW16 on a custom board and the IDE is unable to communicate with the chip. One of my main concern with the programmer is that the yellow light on it is suppose to only lit when a target device power is detected, but it's always ON even if the header isn’t connected to the male 6 pins header on the board. I get the power cycle dialog to enter debug mode with the chip but it never seem to work. The IDE doesn’t seem to be able to do the power cycle correctly with the chip. Sometimes I don't even get the power cycle dialog. Another of my concern is that I'm using a REV. C USB-ML-12E, but in the drivers it shows that its a REV. B. I've tried getting latest drivers for this programmer on P&E website and uninstalling and reinstalling them a coupel time and it,s still not working. Is there a way I can test if the programmer isn't broken?


Thx in advance!


P.S.: The message I get is shown in the following image (I'm currently using CodeWarrior for MCU version: 10.5):


2014-07-10 12-20-00 PM.png

Outcomes