AnsweredAssumed Answered

Why does fastboot sometimes hang?

Question asked by Shane Griffin on Jul 7, 2014
Latest reply on Jul 15, 2014 by Shane Griffin
Branched to a new discussion

Working with custom hardware, using Android BSP for iMX53 ARD.

 

I've recently added fastboot to u-boot, in order to program new kernel/system images to SD card via USB.

 

I've found that fastboot hangs quite frequently. I've got a script that attempts to program 4 images to my SD card, and it never manages to program more than 3 before hanging (usually dies after 2). I have to power-down or unplug my target for the host-side fastboot application to see that something has gone wrong and exit. I've also confirmed that the problem happens when simple fastboot cmds are repeated manually e.g. fastboot getvar version, after just a few iterations.

 

I also noticed that when I run fastboot devices repeatedly, the response changes after a few iterations:

First few times, I get:

1                    fastboot

Then it changes to:

??????????     fastboot

 

I tried deleting the host-side fastboot application that gets built as part of the full Android build, and installed the latest fastboot using apt-get, but the results are exactly the same. Looks like some problem with target-side fastboot library, or possibly something going wrong at USB level in u-boot.

 

Are there any known issues with freescale's target-side fastboot library? Is anybody else using this successfully?

Outcomes