AnsweredAssumed Answered

Issue in setting up ethernet port on t1040qds board.

Question asked by Yashwant Dixit on Jun 27, 2014
Latest reply on Jul 2, 2014 by Yashwant Dixit

Hi,

We are working on t1040qds eval board and able to use it on u-boot prompt but facing issue after linux kernel is booted. Below is the log messages,

 

root@t1040qds:~# ifconfig

lo        Link encap:Local Loopback 

          inet addr:127.0.0.1  Mask:255.0.0.0

          inet6 addr: ::1/128 Scope:Host

          UP LOOPBACK RUNNING  MTU:65536  Metric:1

          RX packets:0 errors:0 dropped:0 overruns:0 frame:0

          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:0

          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

root@t1040qds:~# ifconfig fm1-gb0  5.67.103.15 netmask 255.255.0.0

root@t1040qds:~# route add default gw 5.67.0.1 fm1-gb0

root@t1040qds:~# route -n

Kernel IP routing table

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface

0.0.0.0         5.67.0.1        0.0.0.0         UG    0      0        0 fm1-gb0

5.67.0.0        0.0.0.0         255.255.0.0     U     0      0        0 fm1-gb0

root@t1040qds:~# ifconfig

fm1-gb0   Link encap:Ethernet  HWaddr 00:00:00:00:cd:4b 

          inet addr:5.67.103.15  Bcast:5.67.255.255  Mask:255.255.0.0

          inet6 addr: fe80::200:ff:fe00:cd4b/64 Scope:Link

          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

          RX packets:0 errors:0 dropped:0 overruns:0 frame:0

          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:1000

          RX bytes:0 (0.0 B)  TX bytes:468 (468.0 B)

          Memory:fe4e0000-fe4e0fff

 

lo        Link encap:Local Loopback 

          inet addr:127.0.0.1  Mask:255.0.0.0

          inet6 addr: ::1/128 Scope:Host

          UP LOOPBACK RUNNING  MTU:65536  Metric:1

          RX packets:0 errors:0 dropped:0 overruns:0 frame:0

          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:0

          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

 

root@t1040qds:~# ifconfig fm1-gb0 up

root@t1040qds:~# ping 202.153.144.25

PING 202.153.144.25 (202.153.144.25): 56 data bytes

64 bytes from 5.67.103.15: Destination Host Unreachable

Vr HL TOS  Len   ID Flg  off TTL Pro  cks      Src      Dst Data

4  5  00 0054 0000   2 0000  40  01 73a4 5.67.103.15  202.153.144.25

64 bytes from 5.67.103.15: Destination Host Unreachable


After setting the configuration not able to ping other systems on network. What could be the issue here?

 

-Yashwant

Outcomes