AnsweredAssumed Answered

Regarding YUV422 video encode using VPU

Question asked by Shilpa C on Jun 20, 2014
Latest reply on Nov 19, 2014 by Eric Kang

Hi,

 

I am trying to receive YUV422 format video data using videotestsrc and encode using vpuenc element of gstreamer 0.10. But when I do so ending up in an error.

 

When I saw capabilities of vpuenc gstreamer element using "gst-inspect-0.10 vpuenc", support for YUV422 is not found.

 

While running through gst-fsl-plugins code I observed the availability of two vpu elements "vpuenc" and "mfw_vpuencoder". Looks like mfw_vpuencoder has support for YUV422. But the gst-fsl-plugins rmp installed isn't providing mfw_vpuencoder element on IMX6Q though libraries related to them are available.

 

Set up details

 

Hardware: IMX6Q Sabrelite Eval Board

Release: Yocto 1.4

Build: Linux 3.0.35_1.1.0

Media Framework: GStreamer0.10

 

Need your inputs.

 

Thanks,

Shilpa Chandrappa

Outcomes