AnsweredAssumed Answered

Yocto image using mfgtool.

Question asked by Rohit Reddy on Jun 12, 2014
Latest reply on Jun 23, 2014 by Rohit Reddy

Hi,

 

This is Rohit, I am trying to get yocto wokring on a ARM Board (EMB-3500 iMX6).

 

The board doesn't support booting from Memory card. So we use the mfgtools to flash the image to on board Nand. We have Ubuntu Image which works with no issue.

 

The Ubuntu Image has 3 files,

 

1. rootfs.tar.bz2

2. u-boot.bin

3. uImage

 

I have build a Yocto iMX6qSabreauto core-image-full-cmdline image, copied the "core-image-full-cmdline-imx6qsabreauto.tar.bz2" and "uImage-imx6qsabreauto.bin" in place of "rootfs.tar.bz2" and "uImage"

 

Tried to flash the image to Nand, it fails to boot. I get following error,

 

MMC read: dev # 3, block # 2048, count 8192 ... 8192 blocks read: OK

## Booting kernel from Legacy Image at 10800000 ...

   Image Name:   Linux-3.10.17-1.0.0_ga+g232293e

   Image Type:   ARM Linux Kernel Image (uncompressed)

   Data Size:    5264120 Bytes =  5 MB

   Load Address: 10008000

   Entry Point:  10008000

   Verifying Checksum ... Bad Data CRC

ERROR: can't get kernel image!

 

I have tried to use the working kernel (Ubuntu - uImage). The kernel loads, but the board turns off automatically. I get following message before it turn off,

 

EXT3-fs: barriers not enabled

kjournald starting.  Commit interval 5 seconds

EXT3-fs (mmcblk0p1): using internal journal

EXT3-fs (mmcblk0p1): recovery complete

EXT3-fs (mmcblk0p1): mounted filesystem with writeback data mode

VFS: Mounted root (ext3 filesystem) on device 179:1.

Freeing init memory: 212K

 

Any help in fixing this issue is really appreciated.

 

Thanks,

Rohit

Outcomes