AnsweredAssumed Answered

Hard Fault Interruption - Cpu_ivINT_Hard_Fault doesnt let me debug

Question asked by Kiven Cortes on Jun 10, 2014
Latest reply on Sep 21, 2014 by Erich Styger

Hello, Im Kiven

I'm trying to connect my KL46Z via serial port to a visual studio application. At first I tried the process using the basics components to make the connection work, and it worked! but when I started trying it in my main project this hard fault came up.

I'm using controls like AsynchroSerial, external interruptions and some timers.

The problem is when I am trying to debug it, I get a Debug Halt telling me that it has been stopped because this interruption:




PE_ISR(Cpu_ivINT_Hard_Fault)

{

  /* This code can be changed using the CPU component property "Build Options / Unhandled int code" */

  PE_DEBUGHALT();

}

At first

I made every interruption to work with their own handler using this tutorial Oh my! An Interrupt… | MCU on Eclipse to know what was the real problem and thats what I got.

I don't know where to look or what to change. Thanks in advance for your response!

Greetings!

Outcomes