AnsweredAssumed Answered

No HDMI signal from Nitrogen6x board

Question asked by Peter Bergin on May 21, 2014
Latest reply on Oct 8, 2015 by Mohammed Azlum

Hi,

 

I have built a image for my Nitrogen6x board with Yocto and the daisy branch with linux-boundary 3.10 kernel. When booting my board I can not get any signal out of HDMI. I hope someone can help me with some ideas!

 

root@nitrogen6x:~# uname -a
Linux nitrogen6x 3.10.17-1.0.0_ga+yocto+g731f96d #1 SMP Wed May 21 12:09:44 CEST 2014 armv7l GNU/Linux

 

root@nitrogen6x:~# cat /proc/cmdline
enable_wait_mode=off video=mxcfb0:dev=hdmi,1920x1080M@60,if=RGB24 video=mxcfb1:off video=mxcfb2:off video=mxcfb3:off fbmem=28M console=ttymxc1,115200 vmalloc=400M consoleblank=0 rootwait root=/dev/mmcblk0p2

 

Some printouts from the serial console:

mxc_sdc_fb fb.27: 1920x1080 h_sync,r,l: 44,88,148  v_sync,l,u: 5,4,36 pixclock=148500000 Hz
mxc_sdc_fb fb.27: timeout when waiting for flip irq
mxc_sdc_fb fb.27: timeout when waiting for flip irq
mxc_sdc_fb fb.27: 1920x1080 h_sync,r,l: 44,88,148  v_sync,l,u: 5,4,36 pixclock=148500000 Hz
mxc_sdc_fb fb.27: timeout when waiting for flip irq
mxc_sdc_fb fb.27: timeout when waiting for flip irq
Loading kernel module for a network device with CAP_SYS_MODULE (deprecated).  Use CAP_NET_ADMIN and alias netdev- instead.
mxc_sdc_fb fb.27: timeout when waiting for flip irq
mxc_sdc_fb fb.27: MXCFB_WAIT_FOR_VSYNC: timeout 0
mxc_sdc_fb fb.27: timeout when waiting for flip irq
mxc_sdc_fb fb.27: MXCFB_WAIT_FOR_VSYNC: timeout 0
mxc_sdc_fb fb.27: timeout when waiting for flip irq
mxc_sdc_fb fb.27: MXCFB_WAIT_FOR_VSYNC: timeout 0

 

I have tried with three different displays/TVs with similar result. I have tried HDMI-HDMI and HDMI-DVI cable with similar behaviour.

 

One observation is that u-boot can display content on the screen. When entering u-boot console the version of u-boot is displayed. u-boot can also read EDID information from the screen.

U-Boot 2014.04 (May 19 2014 - 15:20:05)


CPU:   Freescale i.MX6Q rev1.0 at 792 MHz
Reset cause: POR
Board: Nitrogen6X
I2C:   ready
DRAM:  1 GiB
MMC:   FSL_SDHC: 0, FSL_SDHC: 1
SF: Detected SST25VF016B with page size 256 Bytes, erase size 4 KiB, total 2 MiB
auto-detected panel HDMI
Display: HDMI (1024x768)
In:    serial
Out:   serial
Err:   serial
Net:   using phy at 6
FEC [PRIME], usb_ether
Hit any key to stop autoboot:  0
U-Boot > i2c edid 0x50
EDID version: 1.3
Product ID code: 069f
Manufacturer: SAM
Serial number: 43423234
Manufactured in week: 44 year: 2010
Video input definition: digital signal, voltage level 0
Monitor is non-RGB
Maximum visible display size: 52 cm x 29 cm
Power management features: active off, no suspend, no standby
Estabilished timings:
        720x400         70 Hz (VGA 640x400, IBM)
        640x480         60 Hz (VGA)
        640x480         67 Hz (Mac II, Apple)
        640x480         72 Hz (VESA)
        640x480         75 Hz (VESA)
        800x600         56 Hz (VESA)
        800x600         60 Hz (VESA)
        800x600         72 Hz (VESA)
        800x600         75 Hz (VESA)
        832x624         75 Hz (Mac II)
        1024x768        60 Hz (VESA)
        1024x768        70 Hz (VESA)
        1024x768        75 Hz (VESA)
        1280x1024       75 (VESA)
        1152x870        75 (Mac II)
Standard timings:
        1280x800        60 Hz
        1280x960        60 Hz
        1280x1024       60 Hz
        1440x900        60 Hz
        1600x1200       60 Hz
        1680x1050       60 Hz
        1152x864        75 Hz
        1440x900        75 Hz
        1920x1080       60 Hz (detailed)
Monitor range limits, horizontal sync: 30-81 kHz, vertical refresh: 56-75 Hz, max pixel clock: 170 MHz
Monitor name: SMB2440L
Monitor serial number: H9XZB00475
U-Boot >

 

I have also tested with a prebuilt image from Boundary http://boundarydevices.com/yocto-kernel-3-10-17-beta/

With this image I get same behaviour. No signal output on HDMI.

The console:

starting statd: done
imx-ipuv3 2400000.ipu: IPU Warning - IPU_INT_STAT_5 = 0x00800000
mxc_sdc_fb fb.25: 1280x720 h_sync,r,l: 40,110,220  v_sync,l,u: 5,5,20 pixclock=74250000 Hz
imx-ipuv3 2400000.ipu: IPU Warning - IPU_INT_STAT_10 = 0x00080000
mxc_sdc_fb fb.25: timeout when waiting for flip irq
vgaarb: this pci device is not a vga device
Starting advanced power management daemon: No APM support in kernel
(failed.)
NFS daemon support not enabled in kernel
Starting smarthome
imx-ipuv3 2400000.ipu: IPU Warning - IPU_INT_STAT_5 = 0x00800000
mxc_sdc_fb fb.25: 1280x720 h_sync,r,l: 40,110,220  v_sync,l,u: 5,5,20 pixclock=74250000 Hz
imx-ipuv3 2400000.ipu: IPU Warning - IPU_INT_STAT_10 = 0x00080000
imx-ipuv3 2400000.ipu: IPU Warning - IPU_INT_STAT_5 = 0x00800000
mxc_sdc_fb fb.25: 1280x720 h_sync,r,l: 40,110,220  v_sync,l,u: 5,5,20 pixclock=74250000 Hz
imx-ipuv3 2400000.ipu: IPU Warning - IPU_INT_STAT_10 = 0x00080000
vgaarb: this pci device is not a vga device
imx-ipuv3 2400000.ipu: IPU Warning - IPU_INT_STAT_5 = 0x00800000
mxc_sdc_fb fb.25: 1920x1080 h_sync,r,l: 44,528,148  v_sync,l,u: 5,4,36 pixclock=148500000 Hz
imx-ipuv3 2400000.ipu: IPU Warning - IPU_INT_STAT_10 = 0x00080000
libphy: 2188000.ethernet:06 - Link is Up - 100/Half
Starting syslogd/klogd: done
 * Starting Avahi mDNS/DNS-SD Daemon: avahi-daemon
imx-ipuv3 2400000.ipu: IPU Warning - IPU_INT_STAT_5 = 0x00800000
mxc_sdc_fb fb.25: 1920x1080 h_sync,r,l: 44,528,148  v_sync,l,u: 5,4,36 pixclock=148500000 Hz
imx-ipuv3 2400000.ipu: IPU Warning - IPU_INT_STAT_5 = 0x00800000
mxc_sdc_fb fb.25: 1920x1080 h_sync,r,l: 44,528,148  v_sync,l,u: 5,4,36 pixclock=148500000 Hz
   ...done.
Starting Telephony daemon
Starting Linux NFC daemon
Bluetooth: Core ver 2.16
NET: Registered protocol family 31
Bluetooth: HCI device and connection manager initialized
Bluetooth: HCI socket layer initialized
Bluetooth: L2CAP socket layer initialized
Bluetooth: SCO socket layer initialized
Starting OProfileUI server
Running local boot scripts (/etc/rc.local).
Stopping Bootlog daemon: bootlogd.


Poky (Yocto Project Reference Distro) 1.5+snapshot-20140302 nitrogen6x /dev/ttymxc1


nitrogen6x login: Unable to load library icui18n "Cannot load library icui18n: (icui18n: cannot open shared object file: No such file or directory)"
smarthome: cannot connect to X server
imx-ipuv3 2400000.ipu: IPU Warning - IPU_INT_STAT_5 = 0x00800000
mxc_sdc_fb fb.25: 1920x1080 h_sync,r,l: 44,528,148  v_sync,l,u: 5,4,36 pixclock=148500000 Hz

 

 

Thanks,

/Peter

Outcomes