AnsweredAssumed Answered

i.MX6Q SystemOnChip in RecoveryMode

Question asked by Maxime Croizer on May 20, 2014

Hi,

 

After 2 months of good and loyal service, our MarsBoard (an i.mx6 based arm board) stopped working.

I was doing some tests with the USB OTG and linux gadget modules. Everything worked fine, my device was detected by my host PC. Until the marsboard suddently freezed (Unable to type anything).

I rebooted the board, and nothing showed up on the USB-serial output. What could have happened ?

I checked if the device was still detected (using linux command lsusb), it printed this :

  

Bus 002 Device 117: ID 15a2:0054 Freescale Semiconductor, Inc. i.MX6Q SystemOnChip in RecoveryMode

Bus 002 Device 118: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC

 

 

I checked on Internet if anyone had the same problem, and noticed that I was not alone (a few guys using Wandboards, and some other imx6-based boards). Some said it was related with the boot mode selection. I checked the boot mode switch, and noticed no problems.

I checked the power supply, and tried with another one, nothing special.

   

I also tried to re-flash the whole thing (uboot, kernel and rootfs), as the board is still detected by MFG-Tool, with no success. It's stuck on the "temporary" uboot part, and this is what is printed on the serial output :

 

U-Boot 2009.08 (Dec 12 2012 - 12:06:05)

 

 

CPU:   Freescale i.MX 6 family 0.0V at 792 MHz

Temperature:   46 C, calib2ation d!ta 0x5a051569

mx6q pll1: 792MHz

mx6q pll2: 528MHz

mx6q pll3: 480MHz

mx6q pll8: 50MHz

ipg clock     : 25000000Hz

ipg per clock : 25000000Hz

uart clock    : 80000000Hz

cspi clock    : 60000000Hz

ahb clock     : 50000000Hz

axi clock   : 100000000Hz

emi_slow clock: 11111111Hz

ddr clock     : 200000000Hz

usdhc1 clock  : 200000000Hz

usdhc2 clock  : 200000000Hz

usdhc3 clock  : 200000000Hz

usdhc4 clock  : 200000000Hz

nfc #lock     : 19805696Hz

Board: MX6Q-SABRELITE:[ POR]

Boot Device: I2C

I2C:   ready

DRAM:   1 GB

MMC:   FSL_USDHC: 0,FSL_USDHC: 1

Using default environment

   

From what I read, the "SystemOnChip in RecoveryMode" is the SoC mode when it fail to boot on everything it could.

I can't think of anything that could have wreak havoc on the MarsBoard. I had just the g_webcam gadget loaded, had a Ps3Eye plugged, and the usb debug and OTG connected to the PC. Nothing more.

   

If you ever runned into this issue, any solution or hint would be appreciated

   

Thanks,

Outcomes