AnsweredAssumed Answered

Firmware update required

Question asked by Ali Kobari on May 15, 2014
Latest reply on May 21, 2014 by lunminliang

Hello,

I am trying to connect to a target system which is based on p2020 via CW-TAP and using CW- IDE, but I am getting the following error:

 

Error launching Myp2020_project-core00_RAM_P2020_Download

CCSProtocolPlugin : Could not connect to the probe (or other debug link)

[CCS last error: Firmware update required ]

 

 

I did update the firmware by connecting to CW-TAP using ccs.exe in win7 and following command, but I am still getting the same error when I connect to CW-TAP in IDE environment:

 

(bin) 1 % updatecwtap --force 10.92.6.50

10.92.6.50 is running OS version 1.0.1

Update contains OS version 1.0.1

WARNING: Update forced - overriding version check.

WARNING: UPDATING FLASH - DO NOT INTERRUPT!

Sending code to CodeWarrior TAP.........done

Running package script

Erasing kernel partition...

Flashing kernel partition...

Erasing root2 partition...

Flashing root2 partition...

Activating root2

Update completed; rebooting.

Waiting for reboot...

10.92.6.50 is running Boot Loader version 0.9.2

Update contains Boot Loader version 0.9.2

WARNING: Update forced - overriding version check.

WARNING: UPDATING FLASH - DO NOT INTERRUPT!

Sending code to CodeWarrior TAP.........done

Running package script

Erasing uboot partition...

Flashing uboot partition...

Update completed; rebooting.

Waiting for reboot...

All updates completed successfully.

(bin) 2 % updatecwtap 10.92.6.50

10.92.6.50 is running OS version 1.0.1

Update contains OS version 1.0.1

No update needed (use '--force' to reinstall).

10.92.6.50 is running Boot Loader version 0.9.2

Update contains Boot Loader version 0.9.2

No update needed (use '--force' to reinstall).

All updates completed successfully.

(bin) 3 %

 

Thanks

Outcomes