AnsweredAssumed Answered

FRDM-K20D50M not running pre-compiled examples

Question asked by Joao Lugao on May 12, 2014
Latest reply on Sep 5, 2014 by Jorge_Gonzalez

Hi, I just recieved my FRDM-K20D50M board and I'm having trouble with the pre-compiled examples. So far I've tried updating the bootloader, downloading the file MSD-DEBUG-FRDM-K20D50M_Pemicro_v114.SDA to the bootloader of the device and nothing seems to work. I have tried to do this both in windows 8 and windows 7.

When I download an example to the device it stops running the sample code that come with it (blinking the RGB led) and leave a static blue led on. When I press reset nothing happens. sometimes the laststat will show Error 7 and sometimes ready. When I unplug and plug the USB again the original sample code will start running again.

 

FYI

Board Name is: FRDM-K20D50M

MicroBoot Kernel Version is: 1.03

Bootloader Version is: 1.11

Installed Application: PEMicro FRDM-K20D50M Mass Storage/Debug App

Application Version is: 1.14

 

 

 

Can anybody help me? or is my board DOA?

Outcomes