AnsweredAssumed Answered

audio issue: inaudible due to bad echo on iMX53

Question asked by varma siravuri on Apr 25, 2014
Latest reply on Apr 28, 2014 by igorpadykov

CPU - i.MX535

Audio Codec Chip – SGTL5000

Linux – 2.6.35.3

 

I am using VOIP stack on the i.MX53 which works well for the video calls. The issue is with the audio. During a call, there an echo which makes the sound output inaudible. I tweaked the VOIP stack and reduced a little bit of it. Now we further need to tweak into the kernel to reduce the audio latency during capture and playback which will reduce the echo.


I am pretty sure that the VOIP stack is not doing this. On the VOIP side, I am using PCMU and PCMA audio codecs.


Can noise/echo cancellation be achieved either through some kernel configs or settings in audio codec. Is there a built-in echo-cancellation in the SGTL codec chip?

Appreciate any help/pointers in suppressing echo.


Thanks

Varma

Outcomes