AnsweredAssumed Answered

Standby option not available under /sys/power/state

Question asked by Ankur Patel on Apr 17, 2014
Latest reply on Mar 23, 2016 by Jörg Krause

Hello Friends,

 

I am using kernel 3.10.32 on imx28evk board. Please find the attached config file with the post. Even I have selected CONFIG_SUSPEND is selected, there is no standby option under /sys/power/state.

 

Command:

root@imx28evk:~# cat  /sys/power/state

freeze mem

 

Snipp of config file:

CONFIG_SUSPEND=y

CONFIG_SUSPEND_FREEZER=y

CONFIG_PM_SLEEP=y

# CONFIG_PM_AUTOSLEEP is not set

CONFIG_PM_WAKELOCKS=y

CONFIG_PM_WAKELOCKS_LIMIT=100

CONFIG_PM_WAKELOCKS_GC=y

CONFIG_PM_RUNTIME=y

CONFIG_PM=y

CONFIG_PM_DEBUG=y

CONFIG_PM_ADVANCED_DEBUG=y

# CONFIG_PM_TEST_SUSPEND is not set

CONFIG_PM_SLEEP_DEBUG=y

# CONFIG_APM_EMULATION is not set

CONFIG_PM_CLK=y

CONFIG_CPU_PM=y

CONFIG_ARCH_SUSPEND_POSSIBLE=y

CONFIG_ARM_CPU_SUSPEND=y

CONFIG_NET=y

 

Can anyone please give me some hint or clue what I am missing in the config file to enable the standby mode?

 

Regards,

Ankur

Original Attachment has been moved to: config.zip

Outcomes