AnsweredAssumed Answered

mqxboot questions

Question asked by Nouchi on Apr 11, 2014
Latest reply on Apr 16, 2014 by Nouchi

Hello,

 

I encounter difficulties to load and run M4 applications from linux with mqxboot. Applications works fine from debugger.

I build (successfully) and I tried mcc-pingpong demo without success (from timesys wiki).

From Timesys wiki the commande line is : mqxboot pingpong_example_twrvf65gs10_m4.bin 0x3f000000 0x3f000485

0x3f000000 is the load address in internal RAM, right?

and 0x3f000485 is the start address (odd address ???).

When I launch this, it crashes linux (have to hard reset).

Which address should I use ?

In the linker map file this line seems to interesting :

0x3f0004e0   0x00000068   Code   RO1055  * . text    psp.a(boot.o)

In this case 0x3f0004e0 seems to be the entry point.

If I try to launch mqxboot /home/demo-items/accelerometer_example_twrvf65gs10_m4.bin 0x3f000000 0x3f000485 (which is already build), it works.

Is there something to do with DS-5, it seems all things I build don't work.

 

I'm lost, somebody can help me.

 

Regards,

Emmanuel

 

 

Edit :

Now it works but :

- The Start address seems to be the Entry point address + 1

Somebody can explain why "+ 1" ?

Outcomes