AnsweredAssumed Answered

Unable to debug frdm-ke02z using pemicro osjtag

Question asked by Francesco Prosperi on Apr 10, 2014
Latest reply on Apr 22, 2014 by Francesco Prosperi

Hi all,

 

My platform:

 

Windows XP 32bit

KEIL uVision 5.10.0.2

Board: FRDM-KE02Z

 

EDIT: The board is already in debugging mode (flashing DEBUG-APP_Pemicro_v106.SDA from KE02_QSP).

 

Following the howtos from freescale for debugging my application inside uvision using pemicro osjtag,

I tried to install the Freescale Kinetis OSJTAG Drivers V1.18 (fslkinetisdriversv118.exe).

I received errors on each driver the procedure tried to install.

So I opened the Device Manager panel and installed manually from the folder C:\Pemicro with success.

 

Now I have two devices said to be "correctly working" in the Device Manager panel:

Jungo / PEMicro OpenSDA Debug Driver

Ports / OpenSDA CDC Serial Port (COM14)

 

After building the platinum project (ke02_sc.zip) for uvision i tried entering debug.

PEMicro Connection Manager showed up and I selected "OpenSDA Embedded Tower Debug - USB Port".

Unfortunately, the label Port under the selector says: Undetected. Disconnect/Connect USB cable. Click Refresh List.

I tried a few times but nothing happened.

 

Am I doing something wrong?

 

Thanks for the support.

 

EDIT: I tried CMSIS-DAP_OpenSDA.S19 in conjunction with CMSIS-DAP Debugger (uVision debug settings).

The debugging and flashing activities work fine but the CDC serial port is missing.

 

Francesco

Outcomes