AnsweredAssumed Answered

Problems with setting up Linux on Marsboard (iMX6)

Question asked by Alexander Dahmen on Apr 10, 2014
Latest reply on Jun 17, 2014 by Frank Bennett

Hello,

 

I am using the Marsboard iMX6Q and want to run the Linux Image from this site: http://www.element14.com/community/docs/DOC-65093?ICID=knode-sabre-space. I use the MFG tool (Version 1.6.2). The flash operation is successful, but Linux does not boot.

 

By the way, the Android image works fine.

 

I tried to compile my own Linux image by using the sources, but I only get the u-boot.bin and the kernel image (uImage). I dont know how to create the oneiric.tgz.

The replacement of u-boot.bin and the kernel image has no effect.

 

It doesn't matter, if I use a SD card or not (in TF slot of the board). I also tried to copy a Linux image file (.img) to a SD card, which was created for the Marsboard - no effect. To copy the .img I did use the dd command under a Linux system.

 

Does anybody know how to get Linux run on the Marsboard? Is there something special for Linux? (Android works fine)

 

(Display: HDMI)

Outcomes