AnsweredAssumed Answered

Unable to Flash the target in TWR-K64F120M

Question asked by daniel mancuso on Apr 3, 2014
Latest reply on May 9, 2014 by Gary Segal

Hello,

 

I´m trying to flash the K64 target in the TWR-K64F120M using the P&E Debugger.

I´m using Keil uVision V5. When I try to flash, I get ERROR 18 (see picture below). I can see that the Selected device is not MK64, I´ve tried with different K60 targets, and in the PEMICRO Connection Manager window previous programming, is showed "Target CPU: ARM-Autodetect"

Might be this the issue? Where can I find the right target file?

 

P&E_debugger_error.png

I´ve checked the installed bootloader app version and seems to be the last one (v1.14):

OpenOCDversion_in_TWr.png

I´ve also tried with the Toolchain proposed in MCU on Eclipse | Everything on Eclipse, Microcontrollers and Software (Eclipse Kepler + P&E GDB server) and this is the output I get:

P&E Server Error output.png

In the TWR board, I´ve installed J39 (SWD_CLK_TGTMCU), and J10,J15 are in position 2-3 (UART1_TX_K20_EN & UART1_RX_K20_EN connected to the target)

 

Board serial number: 631879-00873-0214-27943

Schematic rev.: 27943 REV B1

 

Thanks in advance.

 

All the best,

Daniel Mancuso -  Hardware Engineer @ relayr.io

Outcomes