AnsweredAssumed Answered

Failed to open libwvm.so

Question asked by frédéric on Apr 1, 2014

We made a board based on the nitrogen6x but without the SGTL5000 codec. We are using linux 3.0.35 and android 4.2.2, pluged on a HDMI TV.

 

To have sound on HDMI, I backported the small patch boundary made to enable hdmi audio (with a setprop sys.hdmi 1), I tried tinyplay without success:

 

root@android:/ # cat /proc/asound/cards

0 [Dummy          ]: Dummy - Dummy

                      Dummy 1

1 [imxhdmisoc     ]: imx-hdmi-soc - imx-hdmi-soc

                      imx-hdmi-soc

 

root@android:/data/media # tinyplay a2002011001-e02.wav -D 1

Unable to open PCM device 0 (cannot set hw params: Invalid argument)

 

And when I change the volume in android, I should hear the standard sound, but I have this in logcat:

 

W/audio_hw_primary( 2347): do_out_standby... 1101573600

W/audio_hw_primary( 2347): card 1, port 0 device 0x2

W/audio_hw_primary( 2347): rate 44100, channel 2 period_size 0x300

E/WVMExtractor( 2347): Failed to open libwvm.so

D/Ringtone( 2888): Successfully created local player

E/WVMExtractor( 2347): Failed to open libwvm.so

D/Ringtone( 2888): Successfully created local player

E/WVMExtractor( 2347): Failed to open libwvm.so

D/Ringtone( 2888): Successfully created local player

E/WVMExtractor( 2347): Failed to open libwvm.so

D/Ringtone( 2888): Successfully created local player

E/WVMExtractor( 2347): Failed to open libwvm.so

 

Where can I find this library? Is this why I do not have sound via HDMI audio?

Outcomes