AnsweredAssumed Answered

How can I use the fnet demo?

Question asked by martinpi on Mar 28, 2014
Latest reply on Apr 2, 2014 by Hui_Ma

Opening the project was the first challenge.

There was a question earlier, and once I managed that, I do not see why I had so much trouble before.

I had tried the importer, I had tried to start CW with the link to the project file as a command line parameter, I dragged it into the wrong sub-window, etc.

 

I tried the mk60n512 shell.

When I tried to build the project, I got errors without a hint where in the file these errors occurred. When I click on the error message, nothing happens. In the directory tree there is no error symbol on any of the files or folders, and the error message in the console does not tell me the cause of the problem, see first snapshot (unlike my own projects, where I do see where errors occurred and I get a more detailed error message).

 

I gave up on that one and this is the closest I got:

 

I created a new bareboard project and added the complete fnet stack. Excluded all but this one demo from the build process.

Then I changed theprogram entry point (properties-->C++ Build-->settings-->Arm linker-->Input) to __startup from the example and also changed the lcf to use the lcf provided in theexample. I had to remove most of the tcp services (fnet_user_config.h) in order to get the program linkable in internal RAM.

As I experienced with other demos, when I tried to run the program in the debugger I got stuck at an endless loop, waiting for "clock status reference bit to set", see second snapshot.

 

Again, I give up on the demo. I do not see how these demos can be helpful for a beginner (and after one year of using Kinetis and CW, I still feel like a beginner).

What am I doing wrong?

 

Greetings, Martin

 

PS: Btw, even the Freescale forum behaves strange. I cannot paste from the clipboard, when I tried to insert snapshots by clicking on the camera symbol above the editor window it did not work, the spell checker results disappear after a few seconds and I have to re-activate the spell checker again,....

Outcomes