AnsweredAssumed Answered

gpu-sdk1008.tgz samples aborting

Question asked by Frank Vasquez on Mar 19, 2014
Latest reply on Mar 24, 2014 by Frank Vasquez

The sample programs in the GPUSDK abort almost immediately when I try to run them on my i.MX537.

 

$ ./es1_lesson02_fbdev

chooseconfig,

es1_lesson02_fbdev: lesson02_imx.c:182: int init(): Assertion `eglGetError() == 0x3000' failed.

Aborted

 

$ ./vg_audiohmi_fbdev

Freescale VG HMI Demo

++Starting Initialization

*eglInitialize

    eglBindAPI

*eglChooseConfig

EGL Fail = EGL_NOT_INITIALIZED (0x3001)

 

I am running on an i.MX537 using an ltib image I built based on a Freescale 2.6.35 kernel.  The GPU shared libraries in my ltib rootfs came from the amd-gpu-bin-mx51-11.09.01 package.  I compiled the GPUSDK samples to use the frame buffer because my image does not have X11 nor do I want it.  I configured the GPUSDK buildvars.mk as follows:

 

 

FSL_PLATFORM = MX53

 

#if building on an LTIB system, set CROSS_COMPILE as below

CROSS_COMPILE = /opt/freescale/usr/local/gcc-4.6.2-glibc-2.13-linaro-multilib-2011.12/fsl-linaro-toolchain/bin/arm-none-linux-gnueabi-

 

#directory with GLES, VG, and EGL headers

FSL_GPU_INC =  $(LTIB_ROOTFS)/usr/include

 

#all other system headers

FSL_PLATFORM_INC = $(LTIB_ROOTFS)/usr/include

 

#location of libEGL.so, etc.

FSL_GPU_LIB = $(LTIB_ROOTFS)/usr/lib

 

#location of other system libraries

FSL_PLATFORM_LIB = $(LTIB_ROOTFS)/usr/lib

 

...

 

C2D_FLAGS = -l2dz430

 

 

Something must be very wrong for EGL to fail.  Any help would be appreciated.

 

-Frank

Outcomes