AnsweredAssumed Answered

NAND flash download of MQX image to TWR-MPC5125 not working

Question asked by Visakhan C on Mar 12, 2014
Latest reply on Apr 11, 2014 by Visakhan C

     I need to program an MQX application, specifically the MQX Ethernet bootloader for MPC5125 tower board, so that the board will boot up with this bootloader (instead of u-boot). The only method for programming NAND flash of TWR-MPC5125 seems to be the 'Ext NAND download' target in the Codewarrior project. As indicated in 'MQX 3.8 getting started', on running(debugging) the MQX project in 'Ext NAND download' target using Codewarrior USBTAP, it will download the bootcode(Block 0 of NAND) and remaining application(Block 1 onwards) to NAND flash.

     I have tried this method for downloading the MQX bootloader, but the board is not booting and not giving a shell prompt. I have also tried the same with other MQX example projects also, but not succeeded.

     Is there any way to correct this problem or a different way to program MQX bootloader to the NAND flash of TWR-MPC5125?

 

Thanks in advance

Visakhan C

Outcomes