AnsweredAssumed Answered

MPC8360 UCC - HDLC

Question asked by Sergey Michailov on Mar 12, 2014
Latest reply on Mar 13, 2014 by Sergey Michailov

There is an MPC8360 with OpenWRT runnung. UCC1 and UCC2 are already used for ethernet. So, I want to use HDLC on other UCC.

There is a 'generic HDLC driver' in kernel. Can I use it? I tried to make it alive, but the only thing I got is "hdlc: HDLC support module revision 1.22" on the start. No devices found, etc. Looks like I nedd to write device tree properly, but I coudn't google an answer. Now I'm using simple

 

ucc@2200 {

  device_type = "network";

  compatible = "ucc_hdlc";

  cell-index = <3>;

  reg = <0x2200 0x200>;

  interrupts = <34>; //0x22

  interrupt-parent = <0x2>;

  rx-clock-name = "none";

  tx-clock-name = "brgo2";

  };

 

but there is no result, as I said before.

Also I've tried to run it (at least) using AppNote 4026, but I get only "Unable to handle kernel paging request for data at address ..." while insmod my .ko even while reading registers, for my UCC and for already working UCCs with ethernet.

What should I do to make it work finally?

Outcomes