AnsweredAssumed Answered

Problem with flash update functions of PE

Question asked by Renjith Vamanan on Feb 23, 2014
Latest reply on Jun 1, 2016 by Theo Barker

Hi

 

I am having some issues with the flash functions of processor expert. I am using TWR-K60F120M tower board.

Some addresses are not getting updated while some others are working properly.

Flash protection bits I have verified, they are all 0xFF meaning the whole flash area is unprotected.

I tried functions like IFsh1_SetLongFlash, IFsh1_SetBlockFlash. For some address they work properly(ie., updates the flash as intended).

But for some addresses like (0x0000A000) they are hanging, and some other lcoations they return success but locations remain as erased state(0xFF).

 

Configuration of flash module:

Write method : Tried with both destructive write and safe write

Command complete interrupt : enabled with med priority

Read collison interrupt : enabled with med priority

Wait in RAM : no

Events enabled in init : yes

Wait enabled in init : yes (hope this ensures that the code waits until a write or erase is complete)

 

NB: I have verified that the addresses I am writing are not occupied by my application.

 

Is there any clues on how to proceed on this ?

 

Thanks,

Renjith

Outcomes