AnsweredAssumed Answered

Building demo program for TWR-K60D100M

Question asked by Markus Braitner on Feb 19, 2014
Latest reply on Mar 20, 2014 by Markus Braitner

Hi,

 

I'm just evaluating K60 using a TWR-K60D100M tower system. To get started, I wanted to re-build the demo program in order to change it and try out some tests this way. After some research I found the CodeWarrior project for the demo program (TWR-K60D100M_Quick_Start_Demo - TWR-K60D100M_QSD_SBCH from TWR-K60D100M: Kinetis K60 100 MHz MCU Tower System Module) and followed the instructions given in TWR-K60D100M_Quick_Start_Demo_Lab_Guide.pdf, but building always exits with approx. 450 errors...

 

I'm using CodeWarrior for MCU, Version 10.5, Build Id 130916

I've also installed MQX 4.0.2 (using FSLMQXOS_4_0_2_GA.exe), imported the libaries for TWR-K60D100M (by importing ..\Freescale_MQX_4_0\config\twrk60d100m\cw10\twrk60d100m.wsd) and re-compiled them (in Debug configuration).

 

Importing the Quick Start Demo project worked, but starting the build process (in debug configuration) always results in a lot of errors (mostly syntax errors, "';' missing" errors and undefined identifiers). For me it seems as CW would not find the MQX libraries (altough I even http://www.freescale.com/webapp/sps/site/prod_summary.jsp?code=TWR-K60D100M&fpsp=1&tab=Design_Tools_Tab) or maybe it is also a problem with interpreting C++ code?

 

One project that I could build was adc_demo in ..\CW MCU v10.5\MCU\CodeWarrior_Examples\Kinetis_Examples\k60\.

 

Any ideas what could be the reason?

 

Greetings from Vienna,

 

Markus

Outcomes