AnsweredAssumed Answered

RSTO stays low on M52259EVB

Question asked by Shaun James on Feb 5, 2014
Latest reply on Feb 7, 2014 by Shaun James

Hi All,

 

I cannot program the MCF52259 on my M52259EVB board through either the inbuilt PE USB debugger or by using a PE Multilink Universal, they lock up when "checking system clock".  I noticed that the Reset LED is on all of the time, it is driven by the RSTO pin.  When I push the reset button, a user LED connected to DTIN0 goes out, then back on again when the button is released.  I've checked the supply voltage and it is 3.3V.  According to the datasheet, the following affect the RSTO pin:   

  • External Reset
  • Watchdog Timer Reset
  • Loss-of-Clock Reset
  • Loss-of-Lock Reset
  • Software Reset
  • LVD Reset

 

I've checked RSTI as being high.

 

I've checked the XTAL clock input with a CRO and confirmed that it gets a 48MHz signal that is the same as on a working M52259DEMO board.  I have confirmed that CLKMOD0 (xtal or external clock) is high (xtal) and CLKMOD1 is high (PLL active).  I've tried CLKMOD1 low (no PLL), same result.

 

I've installed an external 8MHz oscillator module, confirmed the clock with a CRO on the EXTAL pin, set CLKMOD0 low, and tried CLKMOD1 both high and low, still RSTO is low.

 

I tried using the internal oscillator, by setting CLKMOD[1..0] low and pulling XTAL high, RSTO remains low.

 

RSTO goes only to the breakout header, BDM header, the LED, and an onboard CPLD.  It does not go to the onboard P&E BDM.  I cut the trace to the CPLD in case it was a fault there, just in case the CPU was not driving the pin low, though I didn’t think that would disrupt the CPU anyhow.

 

Does anyone have any ideas as to what the trouble could be or suggest what else to try?

 

Thanks,

 

Shaun

Outcomes