AnsweredAssumed Answered

SX-SDCAN on IMX6Q yocto

Question asked by morganmckenzie on Jan 30, 2014
Latest reply on Mar 10, 2014 by morganmckenzie

Hi,

 

I don't know if anyone else has near the same configuration as me - but I've been trying to enable the SX-SDCAN module for my imx6q sabre auto board. I've searched google and come up with a few things but none resulting in a fix, and am going to contact the manufacturer to see if they can help.

 

I've built up an image based on core-image - I haven't configured the kernel but Atheros ath6kl support is enabled as a module. I've tried in dora, master, and master-next with the same results.

 

I was wondering if anyone has had experience with the SX-SDCAN under yocto (and more particularly success?)

 

During the board's boot cycle it gives the following messages:

ath6kl: Failed to get board file ath6k/AR6003/hw2.1.1/bdata.bin (-2), trying to find default board file.

 

ath6kl: Failed to get default board file ath6k/AR6003/hw2.1.1/bdata.SD31.bin: -2

ath6kl: Failed to init ath6kl core

ath6kl_sdio: probe of mmc1:0001:1 failed with error -2

And, these are the contents of /lib/firmware/ath6k/AR6003/hw2.1.1, so it seems to have the things I need there:

athwlan.bin
bdata.SD31.bin
bdata.SD32.bin
bdata.WB31.bin

bdata.bin -> bdata.SD31.bin
bdata.patch.bin
endpointpoing.bin
fw-2.bin
fw-3.bin
opt.bin

 

I've also tried copying over the hw2.1.1 and /lib/drivers/***/devices/net/kernel/ath.ko (that path might not be right, but it is in the device -  I don't currently have access to the computer or board) from the oneiric.tgz release on the freescale website.

 

 

Any help would be much appreciated!

 

 

Morgan McKenzie

Outcomes