AnsweredAssumed Answered

I2C_LDD Component compiles without errors, silence on SDA, SCL pins

Question asked by Yusif Nurizade on Jan 27, 2014

Hello,

 

I posted this question as open for the whole community (No activity on probes after successfully configuring and running I2C_LDD component) but it's been over two weeks so I am hoping this is a more appropriate place to post.

 

A brief summary; I am using Codewarrior 10.5 with Processor Expert. I've configured the I2C_LDD component and copied in sample code I found in Help On Component. I get no errors or warnings but when I go to run the code, the SDA and SCL pins are silent. I tried a fix I found on MCU on Eclipse (KL25Z and I2C: Missing Repeated Start Condition | MCU on Eclipse). I tried reducing the sample code as far down as just the I2C_Init function so I could just see the SCL pin running the clock. I contacted the manufacturer of the IC I am trying to communicate with and corrected my code as per their suggestion. All roads seem to point to the component configuration.

 

I've attached a copy of my initial attempt with the sample code. Later versions stripped out parts like the Term and Util and well as pieces of the code using I2C_LDD all the way down to just leaving the I2C_Init function. I put in the send string functions as a trouble shooting tool and I cannot see any besides the first one so whatever problem I am running into hits by the Init function call. Once I am communicating with the IC, I can reconnect with the manufacturer support but for now I could really use some advice on what's causing the silence.

 

Hope to hear from you,

Yusif Nurizade

Original Attachment has been moved to: I2C_Communication_Attempt_1_8b_2014.zip

Outcomes